rust-gdk0.15

Package information

State
blocked

Scheduler parameters

Package is currently ineligible for scheduling due to following reasons:
  • Package is blocked in koji
Tracked by Koschei
True
Current priority
0
Manual priority
0
Static priority
0
Arch override
None
Skip resolution
False

Configure scheduling

Tracked by Koschei
Manual priority
Skip resolution
Arch override
Cancel

Dependency changes since last build

llvm-libs
18.1.6-2.fc41
18.1.7-1.fc41
2
python3
3.13.0~b2-3.fc41
3.13.0~b2-4.fc41
3
libnghttp2
1.62.0-1.fc41
1.62.1-1.fc41
4
python3-libs
3.13.0~b2-3.fc41
3.13.0~b2-4.fc41
4
kernel-headers
6.10.0-0.rc4.38.fc41
6.10.0-0.rc5.43.fc41
4
ca-certificates
2023.2.62_v7.0.401-6.fc40
2024.2.68_v8.0.302-2.fc41
4
default-fonts-core-sans
4.0-14.fc41
4.1-1.fc41
B
rpm-build
4.19.91-13.fc41
4.19.92-1.fc41
B
pyproject-srpm-macros
1.12.1-1.fc41
1.12.2-1.fc41
B
rpm-libs
4.19.91-13.fc41
4.19.92-1.fc41
B
rpm
4.19.91-13.fc41
4.19.92-1.fc41
B
libicu
74.2-1.fc40
74.2-1.fc41
B
rpm-build-libs
4.19.91-13.fc41
4.19.92-1.fc41
B
python-srpm-macros
3.13-1.fc41
3.13-2.fc41
B
libicu-devel
74.2-1.fc40
74.2-1.fc41
B

Most recent builds

rust
1.79.0-3.fc41
1.79.0-4.fc41
1
libgcc
14.1.1-5.fc41
14.1.1-6.fc41
2
gcc
14.1.1-5.fc41
14.1.1-6.fc41
2
libstdc++
14.1.1-5.fc41
14.1.1-6.fc41
2
cargo
1.79.0-3.fc41
1.79.0-4.fc41
2
rust-std-static
1.79.0-3.fc41
1.79.0-4.fc41
2
zlib-ng-compat
2.1.6-6.fc41
2.1.7-1.fc41
3
cpp
14.1.1-5.fc41
14.1.1-6.fc41
3
sqlite-libs
3.46.0-1.fc41
3.46.0-2.fc41
3
libgomp
14.1.1-5.fc41
14.1.1-6.fc41
3
glib2
2.80.2-1.fc41
2.80.3-1.fc41
4
harfbuzz
8.4.0-1.fc41
8.5.0-1.fc41
4
glib2-devel
2.80.2-1.fc41
2.80.3-1.fc41
4
kernel-headers
6.10.0-0.rc3.31.fc41
6.10.0-0.rc4.38.fc41
4
alternatives
1.27-1.fc41
1.28-1.fc41
4
zlib-ng-compat-devel
2.1.6-6.fc41
2.1.7-1.fc41
B
rust-proc-macro2+proc-macro-devel
1.0.85-1.fc41
1.0.86-1.fc41
B
gcc-plugin-annobin
14.1.1-5.fc41
14.1.1-6.fc41
B
xz
1:5.4.6-3.fc41
1:5.6.2-1.fc41
B
systemd-libs
256-1.fc41
256.1-3.fc41
B
default-fonts-core-sans
4.0-13.fc41
4.0-14.fc41
B
fedora-release
41-0.13
41-0.14
B
fedora-release-common
41-0.13
41-0.14
B
rust-syn+clone-impls-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
xz-libs
1:5.4.6-3.fc41
1:5.6.2-1.fc41
B
rust-syn-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
xz-devel
1:5.4.6-3.fc41
1:5.6.2-1.fc41
B
rust-syn+default-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
rust-syn+proc-macro-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
cyrus-sasl-lib
2.1.28-22.fc41
2.1.28-24.fc41
B
gdb-minimal
14.2-11.fc41
14.2-12.fc41
B
rust-syn+derive-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
nettle
3.9.1-6.fc40
3.10-2.fc41
B
mesa-libGL
24.1.1-4.fc41
24.1.2-1.fc41
B
mesa-libglapi
24.1.1-4.fc41
24.1.2-1.fc41
B
harfbuzz-devel
8.4.0-1.fc41
8.5.0-1.fc41
B
fonts-filesystem
1:2.0.5-15.fc41
1:2.0.5-16.fc41
B
mesa-libgbm
24.1.1-4.fc41
24.1.2-1.fc41
B
harfbuzz-icu
8.4.0-1.fc41
8.5.0-1.fc41
B
mesa-libEGL
24.1.1-4.fc41
24.1.2-1.fc41
B
gnutls
3.8.5-2.fc41
3.8.5-5.fc41
B
rust-syn+printing-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
xml-common
0.6.3-63.fc40
0.6.3-64.fc41
B
add-determinism
0.3.0-1.fc41
0.3.1-1.fc41
B
fedora-release-identity-basic
41-0.13
41-0.14
B
build-reproducibility-srpm-macros
0.3.0-1.fc41
0.3.1-1.fc41
B
rust-proc-macro2-devel
1.0.85-1.fc41
1.0.86-1.fc41
B
rust-proc-macro2+default-devel
1.0.85-1.fc41
1.0.86-1.fc41
B
fonts-srpm-macros
1:2.0.5-15.fc41
1:2.0.5-16.fc41
B
rust-syn+parsing-devel
2.0.66-1.fc41
2.0.67-1.fc41
B
rust
1.78.0-1.fc41
1.79.0-3.fc41
1
rust-std-static
1.78.0-1.fc41
1.79.0-3.fc41
2
cargo
1.78.0-1.fc41
1.79.0-3.fc41
2
glibc
2.39.9000-18.fc41
2.39.9000-26.fc41
2
cargo2rpm
0.1.16-1.fc41
0.1.16-2.fc41
2
glibc-minimal-langpack
2.39.9000-18.fc41
2.39.9000-26.fc41
3
glibc-common
2.39.9000-18.fc41
2.39.9000-26.fc41
3
glibc-gconv-extra
2.39.9000-18.fc41
2.39.9000-26.fc41
3
glibc-devel
2.39.9000-18.fc41
2.39.9000-26.fc41
3
python3
3.12.3-2.fc41
3.13.0~b2-3.fc41
3
libbrotli
1.1.0-3.fc40
1.1.0-4.fc41
4
glibc-headers-x86
2.39.9000-18.fc41
2.39.9000-26.fc41
4
python3-libs
3.12.3-2.fc41
3.13.0~b2-3.fc41
4
fribidi-devel
1.0.14-2.fc41
1.0.15-1.fc41
4
pango
1.52.2-1.fc41
1.54.0-1.fc41
4
kernel-headers
6.10.0-0.rc2.24.fc41
6.10.0-0.rc3.31.fc41
4
pango-devel
1.52.2-1.fc41
1.54.0-1.fc41
4
openldap
2.6.8-1.fc41
2.6.8-2.fc41
4
rust-memchr+std-devel
2.7.2-1.fc41
2.7.4-1.fc41
B
libcap-ng
0.8.5-1.fc41
0.8.5-2.fc41
B
add-determinism
0.2.0-9.fc41
0.3.0-1.fc41
B
libblkid-devel
2.40.1-1.fc41
2.40.1-2.fc41
B
mesa-libgbm
24.1.1-2.fc41
24.1.1-4.fc41
B
rpm-build-libs
4.19.91-8.fc41
4.19.91-13.fc41
B
libstemmer
2.2.0-10.fc40
2.2.0-11.fc41
B
rpm
4.19.91-8.fc41
4.19.91-13.fc41
B
libfdisk
2.40.1-1.fc41
2.40.1-2.fc41
B
libsemanage
3.6-3.fc40
3.6-4.fc41
B
libselinux-devel
3.6-4.fc40
3.6-6.fc41
B
systemd-libs
256~rc4-2.fc41
256-1.fc41
B
libxml2-devel
2.12.7-1.fc41
2.12.8-1.fc41
B
rust-memchr-devel
2.7.2-1.fc41
2.7.4-1.fc41
B
libselinux
3.6-4.fc40
3.6-6.fc41
B
mesa-libGL
24.1.1-2.fc41
24.1.1-4.fc41
B
libmount-devel
2.40.1-1.fc41
2.40.1-2.fc41
B
rust-anyhow-devel
1.0.84-1.fc41
1.0.86-1.fc41
B
libxml2
2.12.7-1.fc41
2.12.8-1.fc41
B
file-libs
5.45-5.fc41
5.45-6.fc41
B
google-noto-sans-vf-fonts
20240401-1.fc41
20240601-1.fc41
B
build-reproducibility-srpm-macros
0.2.0-9.fc41
0.3.0-1.fc41
B
util-linux-core
2.40.1-1.fc41
2.40.1-2.fc41
B
rust-toml_edit+parse-devel
0.22.13-1.fc41
0.22.14-1.fc41
B
rust-toml_edit+serde-devel
0.22.13-1.fc41
0.22.14-1.fc41
B
libmount
2.40.1-1.fc41
2.40.1-2.fc41
B
rust-anyhow+std-devel
1.0.84-1.fc41
1.0.86-1.fc41
B
rust-anyhow+default-devel
1.0.84-1.fc41
1.0.86-1.fc41
B
libpwquality
1.4.5-9.fc40
1.4.5-10.fc41
B
util-linux
2.40.1-1.fc41
2.40.1-2.fc41
B
python3-packaging
24.0-1.fc41
24.1-1.fc41
B
brotli-devel
1.1.0-3.fc40
1.1.0-4.fc41
B
rust-toml-devel
0.8.12-1.fc41
0.8.14-1.fc41
B
libuuid
2.40.1-1.fc41
2.40.1-2.fc41
B
gdb-minimal
14.2-9.fc41
14.2-11.fc41
B
xkeyboard-config
2.41-1.fc40
2.42-1.fc41
B
annobin-docs
12.54-2.fc41
12.59-1.fc41
B
python-pip-wheel
24.0-2.fc41
24.0-5.fc41
B
redhat-rpm-config
292-1.fc41
293-1.fc41
B
cmake-filesystem
3.28.3-5.fc41
3.28.3-6.fc41
B
fribidi
1.0.14-2.fc41
1.0.15-1.fc41
B
rust-memchr+alloc-devel
2.7.2-1.fc41
2.7.4-1.fc41
B
google-noto-fonts-common
20240401-1.fc41
20240601-1.fc41
B
rust-toml+parse-devel
0.8.12-1.fc41
0.8.14-1.fc41
B
annobin-plugin-gcc
12.54-2.fc41
12.59-1.fc41
B
audit-libs
4.0.1-2.fc41
4.0.1-3.fc41
B
perl-srpm-macros
1-53.fc40
1-55.fc41
B
rpm-libs
4.19.91-8.fc41
4.19.91-13.fc41
B
add-determinism-nopython
0.2.0-9.fc41
file
5.45-5.fc41
5.45-6.fc41
B
brotli
1.1.0-3.fc40
1.1.0-4.fc41
B
rust-toml_edit-devel
0.22.13-1.fc41
0.22.14-1.fc41
B
rpm-build
4.19.91-8.fc41
4.19.91-13.fc41
B
mesa-libEGL
24.1.1-2.fc41
24.1.1-4.fc41
B
libblkid
2.40.1-1.fc41
2.40.1-2.fc41
B
mesa-libglapi
24.1.1-2.fc41
24.1.1-4.fc41
B
libsmartcols
2.40.1-1.fc41
2.40.1-2.fc41
B
python-srpm-macros
3.12-9.fc41
3.13-1.fc41
B
2024-06-12 08:56:28
Package dependencies resolved successfuly
2024-06-12 08:49:28
Package resolution failed
  • Problem: package rust-gobject-sys0.15+default-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires crate(gobject-sys) = 0.15.10, but none of the providers can be installed
    - package rust-glib0.15-devel-0.15.12-5.fc41.noarch from primary-f41-build-6163033 requires (crate(gobject-sys/default) >= 0.15.1 with crate(gobject-sys/default) < 0.16.0~), but none of the providers can be installed
    - package rust-gobject-sys0.15-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires pkgconfig(gobject-2.0) >= 2.48, but none of the providers can be installed
    - package rust-glib0.15+default-devel-0.15.12-5.fc41.noarch from primary-f41-build-6163033 requires crate(glib) = 0.15.12, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package rust-gdk-pixbuf-sys0.15+default-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires crate(gdk-pixbuf-sys) = 0.15.10, but none of the providers can be installed
    - package rust-gdk-pixbuf-sys0.15-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires pkgconfig(gdk-pixbuf-2.0) >= 2.32, but none of the providers can be installed
    - package rust-gdk-pixbuf0.15-devel-0.15.11-4.fc40.noarch from primary-f41-build-6163033 requires (crate(gdk-pixbuf-sys/default) >= 0.15.1 with crate(gdk-pixbuf-sys/default) < 0.16.0~), but none of the providers can be installed
    - package gdk-pixbuf2-devel-2.42.12-1.fc41.x86_64 from primary-f41-build-6163033 requires glib2-devel(x86-64) >= 2.56.0, but none of the providers can be installed
    - package gdk-pixbuf2-devel-2.42.12-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gio-2.0) >= 2.56.0, but none of the providers can be installed
    - package gdk-pixbuf2-devel-2.42.12-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(glib-2.0) >= 2.56.0, but none of the providers can be installed
    - package gdk-pixbuf2-devel-2.42.12-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gmodule-no-export-2.0) >= 2.56.0, but none of the providers can be installed
    - package gdk-pixbuf2-devel-2.42.12-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gobject-2.0) >= 2.56.0, but none of the providers can be installed
    - package rust-gdk-pixbuf0.15+default-devel-0.15.11-4.fc40.noarch from primary-f41-build-6163033 requires crate(gdk-pixbuf) = 0.15.11, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package rust-pango-sys0.15+default-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires crate(pango-sys) = 0.15.10, but none of the providers can be installed
    - package rust-pango-sys0.15-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires pkgconfig(pango) >= 1.38, but none of the providers can be installed
    - package rust-pango0.15-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires (crate(pango-sys/default) >= 0.15.1 with crate(pango-sys/default) < 0.16.0~), but none of the providers can be installed
    - package pango-devel-1.52.2-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(glib-2.0) >= 2.62, but none of the providers can be installed
    - package pango-devel-1.52.2-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gio-2.0) >= 2.62, but none of the providers can be installed
    - package pango-devel-1.52.2-1.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gobject-2.0) >= 2.62, but none of the providers can be installed
    - package pango-devel-1.52.2-1.fc41.x86_64 from primary-f41-build-6163033 requires glib2-devel(x86-64) >= 2.62, but none of the providers can be installed
    - package rust-pango0.15+default-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires crate(pango) = 0.15.10, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package rust-cairo-sys-rs0.15+use_glib-devel-0.15.1-4.fc40.noarch from primary-f41-build-6163033 requires ((pkgconfig(cairo-gobject) >= 1.16 if crate(cairo-sys-rs/v1_16)) and pkgconfig(cairo-gobject) >= 1.14), but none of the providers can be installed
    - package rust-cairo-rs0.15+use_glib-devel-0.15.12-4.fc40.noarch from primary-f41-build-6163033 requires (crate(cairo-sys-rs/use_glib) >= 0.15.1 with crate(cairo-sys-rs/use_glib) < 0.16.0~), but none of the providers can be installed
    - package cairo-gobject-devel-1.18.0-3.fc40.x86_64 from primary-f41-build-6163033 requires pkgconfig(glib-2.0) >= 2.14, but none of the providers can be installed
    - package cairo-gobject-devel-1.18.0-3.fc40.x86_64 from primary-f41-build-6163033 requires pkgconfig(gobject-2.0), but none of the providers can be installed
    - package rust-cairo-rs0.15+default-devel-0.15.12-4.fc40.noarch from primary-f41-build-6163033 requires crate(cairo-rs/use_glib) = 0.15.12, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package rust-gio-sys0.15+default-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires crate(gio-sys) = 0.15.10, but none of the providers can be installed
    - package rust-gio0.15-devel-0.15.12-4.fc40.noarch from primary-f41-build-6163033 requires (crate(gio-sys/default) >= 0.15.1 with crate(gio-sys/default) < 0.16.0~), but none of the providers can be installed
    - package rust-gio-sys0.15-devel-0.15.10-4.fc40.noarch from primary-f41-build-6163033 requires pkgconfig(gio-2.0) >= 2.48, but none of the providers can be installed
    - package rust-gio0.15+default-devel-0.15.12-4.fc40.noarch from primary-f41-build-6163033 requires crate(gio) = 0.15.12, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package cargo-rpm-macros-26.3-1.fc41.noarch from primary-f41-build-6163033 requires cargo2rpm >= 0.1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by cargo2rpm-0.1.16-2.fc41.noarch from primary-f41-build-6163033
  • Problem: package rust-gdk-sys0.15-devel-0.15.1-4.fc40.noarch from primary-f41-build-6163033 requires pkgconfig(gdk-3.0) >= 3.18, but none of the providers can be installed
    - package gtk3-devel-3.24.42-2.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gio-2.0) >= 2.57.2, but none of the providers can be installed
    - package gtk3-devel-3.24.42-2.fc41.x86_64 from primary-f41-build-6163033 requires pkgconfig(gio-unix-2.0) >= 2.57.2, but none of the providers can be installed
    - package rust-gdk-sys0.15+default-devel-0.15.1-4.fc40.noarch from primary-f41-build-6163033 requires crate(gdk-sys) = 0.15.1, but none of the providers can be installed
    - package glib2-devel-2.80.2-1.fc41.x86_64 from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
2024-06-12 08:43:53
Package resolution failed
  • Problem: package cargo-rpm-macros-26.3-1.fc41.noarch from primary-f41-build-6162980 requires cargo2rpm >= 0.1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by cargo2rpm-0.1.16-2.fc41.noarch from primary-f41-build-6162980
2024-06-12 08:32:59
Package resolution failed
  • Problem: package cargo-rpm-macros-26.3-1.fc41.noarch from primary-f41-build-6162913 requires cargo2rpm >= 0.1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by cargo2rpm-0.1.16-2.fc41.noarch from primary-f41-build-6162913
2024-06-12 08:29:14
Package resolution failed
  • Problem: package cargo-rpm-macros-26.3-1.fc41.noarch from primary-f41-build-6162843 requires cargo2rpm >= 0.1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by cargo2rpm-0.1.16-2.fc41.noarch from primary-f41-build-6162843
2024-06-12 08:23:57
Package resolution failed
  • Problem: package cargo-rpm-macros-26.3-1.fc41.noarch from primary-f41-build-6162796 requires cargo2rpm >= 0.1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by cargo2rpm-0.1.16-2.fc41.noarch from primary-f41-build-6162796
Previous history