rust-cargo

Package information

State
unresolved

Scheduler parameters

Package is currently ineligible for scheduling due to following reasons:
  • Package dependencies are not resolvable
Tracked by Koschei
True
Current priority
0
Manual priority
0
Static priority
0
Arch override
None
Skip resolution
False

Configure scheduling

Tracked by Koschei
Manual priority
Skip resolution
Arch override
Cancel

Dependency changes since last build

No dependency changes

Most recent builds

2019-11-19 11:22:31
Package resolution failed
  • No package found for: (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0)
  • Problem: package rust-git2-curl+default-devel-0.10.0-2.fc31.noarch requires crate(git2-curl) = 0.10.0, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(git2) >= 0.9.0 with crate(git2) < 0.10.0) needed by rust-git2-curl-devel-0.10.0-2.fc31.noarch
  • No package found for: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
  • No package found for: (crate(git2/default) >= 0.9.0 with crate(git2/default) < 0.10.0)
  • Problem: package rust-crypto-hash+default-devel-0.3.4-1.fc32.noarch requires crate(crypto-hash) = 0.3.4, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0) needed by rust-crypto-hash-devel-0.3.4-1.fc32.noarch
2019-11-19 10:54:10
Package resolution failed
  • No package found for: (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0)
  • Problem: package rust-git2-curl+default-devel-0.10.0-2.fc31.noarch requires crate(git2-curl) = 0.10.0, but none of the providers can be installed
    - package rust-git2-curl-devel-0.10.0-2.fc31.noarch requires (crate(git2) >= 0.9.0 with crate(git2) < 0.10.0), but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • Problem: package rust-git2+default-devel-0.9.1-3.fc31.noarch requires crate(git2) = 0.9.1, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • No package found for: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
  • Problem: package rust-crypto-hash+default-devel-0.3.4-1.fc32.noarch requires crate(crypto-hash) = 0.3.4, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0) needed by rust-crypto-hash-devel-0.3.4-1.fc32.noarch
2019-11-19 10:44:36
Package resolution failed
  • Problem: package rust-git2+default-devel-0.9.1-3.fc31.noarch requires crate(git2) = 0.9.1, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • No package found for: (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0)
  • Problem: package rust-git2-curl+default-devel-0.10.0-2.fc31.noarch requires crate(git2-curl) = 0.10.0, but none of the providers can be installed
    - package rust-git2-curl-devel-0.10.0-2.fc31.noarch requires (crate(git2) >= 0.9.0 with crate(git2) < 0.10.0), but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • No package found for: (crate(crossbeam-utils/default) >= 0.6.0 with crate(crossbeam-utils/default) < 0.7.0)
  • Problem: package rust-ignore-devel-0.4.10-1.fc32.noarch requires (crate(crossbeam-channel/default) >= 0.3.6 with crate(crossbeam-channel/default) < 0.4.0), but none of the providers can be installed
    - package rust-ignore+default-devel-0.4.10-1.fc32.noarch requires crate(ignore) = 0.4.10, but none of the providers can be installed
    - package rust-crossbeam-channel+default-devel-0.3.9-1.fc31.noarch requires crate(crossbeam-channel) = 0.3.9, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(crossbeam-utils/default) >= 0.6.5 with crate(crossbeam-utils/default) < 0.7.0) needed by rust-crossbeam-channel-devel-0.3.9-1.fc31.noarch
  • No package found for: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
  • Problem: package rust-crypto-hash+default-devel-0.3.4-1.fc32.noarch requires crate(crypto-hash) = 0.3.4, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0) needed by rust-crypto-hash-devel-0.3.4-1.fc32.noarch
2019-11-19 10:34:27
Package resolution failed
  • No package found for: (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0)
  • Problem: package rust-git2-curl+default-devel-0.10.0-2.fc31.noarch requires crate(git2-curl) = 0.10.0, but none of the providers can be installed
    - package rust-git2-curl-devel-0.10.0-2.fc31.noarch requires (crate(git2) >= 0.9.0 with crate(git2) < 0.10.0), but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • Problem: package rust-git2+default-devel-0.9.1-3.fc31.noarch requires crate(git2) = 0.9.1, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(libgit2-sys/default) >= 0.8.0 with crate(libgit2-sys/default) < 0.9.0) needed by rust-git2-devel-0.9.1-3.fc31.noarch
  • No package found for: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
  • Problem: package rust-crypto-hash+default-devel-0.3.4-1.fc32.noarch requires crate(crypto-hash) = 0.3.4, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0) needed by rust-crypto-hash-devel-0.3.4-1.fc32.noarch
2019-11-19 08:56:51
Package resolution failed
  • Problem: package rust-crypto-hash+default-devel-0.3.4-1.fc32.noarch requires crate(crypto-hash) = 0.3.4, but none of the providers can be installed
    - conflicting requests
    - nothing provides (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0) needed by rust-crypto-hash-devel-0.3.4-1.fc32.noarch
  • No package found for: (crate(hex/default) >= 0.3.0 with crate(hex/default) < 0.4.0)
rust-jobserver+default-devel
0.1.13-2.fc31
0.1.17-1.fc32
1
rust-jobserver-devel
0.1.13-2.fc31
0.1.17-1.fc32
2
rust
1.39.0-1.fc32
1.39.0-2.fc32
2
cargo
1.39.0-1.fc32
1.39.0-2.fc32
2
libcurl
7.67.0-1.fc32
7.67.0-2.fc32
3
glibc
2.30.9000-17.fc32
2.30.9000-18.fc32
3
rust-bitflags+default-devel
1.2.0-1.fc32
1.2.1-1.fc32
3
glibc-devel
2.30.9000-17.fc32
2.30.9000-18.fc32
3
libcurl-devel
7.67.0-1.fc32
7.67.0-2.fc32
3
rust-cc+default-devel
1.0.37-4.fc31
1.0.47-1.fc32
3
python3-tqdm
4.36.1-1.fc32
4.37.0-1.fc32
3
python3-setuptools
41.2.0-1.fc32
41.6.0-1.fc32
3
rust-std-static
1.39.0-1.fc32
1.39.0-2.fc32
3
openssl-libs
1:1.1.1d-2.fc32
1:1.1.1d-4.fc32
3
binutils
2.33.1-6.fc32
2.33.1-7.fc32
4
krb5-libs
1.17-46.fc32
1.17-47.fc32
4
python3-chardet
3.0.4-13.fc32
3.0.4-14.fc32
4
openssl-devel
1:1.1.1d-2.fc32
1:1.1.1d-4.fc32
4
ncurses-libs
6.1-13.20191026.fc32
6.1-14.20191109.fc32
4
libnghttp2
1.39.2-1.fc32
1.40.0-1.fc32
4
glibc-headers
2.30.9000-17.fc32
2.30.9000-18.fc32
4
rust-cc-devel
1.0.37-4.fc31
1.0.47-1.fc32
4
glibc-common
2.30.9000-17.fc32
2.30.9000-18.fc32
4
rust-bitflags-devel
1.2.0-1.fc32
1.2.1-1.fc32
4
python3-urllib3
1.25.6-1.fc32
1.25.7-1.fc32
4
glibc-minimal-langpack
2.30.9000-17.fc32
2.30.9000-18.fc32
4
libselinux
2.9-7.fc32
3.0-0.r1.1.fc32
B
libsepol
2.9-2.fc31
3.0-0.rc.1.fc32
B
curl
7.67.0-1.fc32
7.67.0-2.fc32
B
rust-ppv-lite86+simd-devel
0.2.5-1.fc31
0.2.6-1.fc32
B
rust-c2-chacha+std-devel
0.2.2-1.fc31
0.2.3-1.fc32
B
rust-c2-chacha-devel
0.2.2-1.fc31
0.2.3-1.fc32
B
rust-ppv-lite86-devel
0.2.5-1.fc31
0.2.6-1.fc32
B
rpm-build
4.15.0-6.fc32
4.15.0-7.fc32
B
rust-ppv-lite86+std-devel
0.2.5-1.fc31
0.2.6-1.fc32
B
rust-c2-chacha+simd-devel
0.2.2-1.fc31
0.2.3-1.fc32
B
ncurses-base
6.1-13.20191026.fc32
6.1-14.20191109.fc32
B
python-setuptools-wheel
41.2.0-1.fc32
41.6.0-1.fc32
B
annobin
8.88-1.fc32
8.90-1.fc32
B
ncurses
6.1-13.20191026.fc32
6.1-14.20191109.fc32
B
pcre2
10.33-15.fc32
10.34-0.1.RC2.fc32
B
rpm-libs
4.15.0-6.fc32
4.15.0-7.fc32
B
rpm
4.15.0-6.fc32
4.15.0-7.fc32
B
libsemanage
2.9-5.fc32
3.0-0.rc1.1.fc32
B
binutils-gold
2.33.1-6.fc32
2.33.1-7.fc32
B
rpm-build-libs
4.15.0-6.fc32
4.15.0-7.fc32
B
rust-ppv-lite86+default-devel
0.2.5-1.fc31
python3-pysocks
1.7.1-1.fc32
1.7.1-2.fc32
B
cargo
1.38.0-2.fc32
1.39.0-1.fc32
2
rust
1.38.0-2.fc32
1.39.0-1.fc32
2
glibc
2.30.9000-15.fc32
2.30.9000-17.fc32
3
libcurl
7.66.0-1.fc32
7.67.0-1.fc32
3
zlib
1.2.11-19.fc32
1.2.11-20.fc32
3
glibc-devel
2.30.9000-15.fc32
2.30.9000-17.fc32
3
libssh2
1.9.0-2.fc31
1.9.0-3.fc32
3
rust-std-static
1.38.0-2.fc32
1.39.0-1.fc32
3
libcurl-devel
7.66.0-1.fc32
7.67.0-1.fc32
3
binutils
2.33.1-1.fc32
2.33.1-6.fc32
4
zlib-devel
1.2.11-19.fc32
1.2.11-20.fc32
4
glibc-common
2.30.9000-15.fc32
2.30.9000-17.fc32
4
python3-babel
2.7.0-5.fc32
2.7.0-7.fc32
4
glibc-minimal-langpack
2.30.9000-15.fc32
2.30.9000-17.fc32
4
libssh
0.9.0-6.fc31
0.9.2-1.fc32
4
crypto-policies
20190816-4.gitbb9bf99....
20191002-1.gitc93dc99....
4
ncurses-libs
6.1-12.20190803.fc31
6.1-13.20191026.fc32
4
glibc-headers
2.30.9000-15.fc32
2.30.9000-17.fc32
4
binutils-gold
2.33.1-1.fc32
2.33.1-6.fc32
B
redhat-rpm-config
141-2.fc32
142-1.fc32
B
ncurses-base
6.1-12.20190803.fc31
6.1-13.20191026.fc32
B
which
2.21-15.fc31
2.21-16.fc32
B
libtirpc
1.1.4-2.rc3.fc32
1.1.4-3.rc3.fc32
B
ncurses
6.1-12.20190803.fc31
6.1-13.20191026.fc32
B
audit-libs
3.0-0.14.20190507...
3.0-0.15.20191104...
B
libssh2-devel
1.9.0-2.fc31
1.9.0-3.fc32
B
libssh-config
0.9.0-6.fc31
0.9.2-1.fc32
B
annobin
8.87-1.fc32
8.88-1.fc32
B
curl
7.66.0-1.fc32
7.67.0-1.fc32
B
kernel-headers
5.4.0-0.rc1.git0.1....
5.4.0-0.rc6.git0.1....
B
libxml2
2.9.9-6.fc32
2.9.10-1.fc32
B
fedora-release
32-0.3
32-0.4
B
fedora-release-common
32-0.3
32-0.4
B
pcre2
10.33-14.fc32
10.33-15.fc32
B
libpwquality
1.4.1-1.fc32
1.4.2-1.fc32
B
python-pip-wheel
19.2.3-1.fc32
19.2.3-2.fc32
B
rust-libc+default-devel
0.2.62-1.fc32
0.2.65-1.fc32
1
rust-libc-devel
0.2.62-1.fc32
0.2.65-1.fc32
2
rust-libc+std-devel
0.2.62-1.fc32
0.2.65-1.fc32
2
glibc
2.30.9000-12.fc32
2.30.9000-15.fc32
3
glibc-devel
2.30.9000-12.fc32
2.30.9000-15.fc32
3
libedit
3.1-28.20190324cv...
3.1-29.20191025cv...
4
glibc-headers
2.30.9000-12.fc32
2.30.9000-15.fc32
4
glibc-common
2.30.9000-12.fc32
2.30.9000-15.fc32
4
glibc-minimal-langpack
2.30.9000-12.fc32
2.30.9000-15.fc32
4
file
5.37-7.fc32
5.37-8.fc32
B
rust-getrandom-devel
0.1.11-1.fc32
0.1.13-1.fc32
B
rpm-build-libs
4.15.0-5.fc32
4.15.0-6.fc32
B
file-libs
5.37-7.fc32
5.37-8.fc32
B
rpm-libs
4.15.0-5.fc32
4.15.0-6.fc32
B
rpm-build
4.15.0-5.fc32
4.15.0-6.fc32
B
unzip
6.0-44.fc31
6.0-45.fc32
B
rust-getrandom+default-devel
0.1.11-1.fc32
0.1.13-1.fc32
B
rpm
4.15.0-5.fc32
4.15.0-6.fc32
B
rust-getrandom+std-devel
0.1.11-1.fc32
0.1.13-1.fc32
B
Previous history