python-anyio

Package information

State
ok

Scheduler parameters

Tracked by Koschei
True
Current priority
842
Manual priority
0
Static priority
0
Arch override
None
Skip resolution
False

Configure scheduling

Tracked by Koschei
Manual priority
Skip resolution
Arch override
Cancel

Dependency changes since last build

python3-requests
2.31.0-7.fc41
2.32.3-1.fc41
2
python3-babel
2.15.0-2.fc41~bootstrap
2.15.0-3.fc41
2
xz-libs
1:5.4.6-3.fc41
1:5.6.2-1.fc41
3
xz
1:5.4.6-3.fc41
1:5.6.2-1.fc41
3
fonts-filesystem
1:2.0.5-15.fc41
1:2.0.5-16.fc41
3
fonts-srpm-macros
1:2.0.5-15.fc41
1:2.0.5-16.fc41
4
build-reproducibility-srpm-macros
0.3.0-2.fc41
0.3.1-1.fc41
4
cyrus-sasl-lib
2.1.28-22.fc41
2.1.28-24.fc41
B
add-determinism
0.3.0-2.fc41
0.3.1-1.fc41
B

Groups

This package is not part of any global group.

Most recent builds

complete
2024-06-19 09:16:26
python3-pytest-mock
3.12.0-5.fc41
3.14.0-1.fc41
1
python3-packaging
24.0-3.fc41
24.1-1.fc41
1
glibc
2.39.9000-18.fc41
2.39.9000-26.fc41
2
python3-requests
2.31.0-6.fc41
2.31.0-7.fc41
2
rpm-build
4.19.91-9.fc41
4.19.91-13.fc41
2
python3-typing-extensions
4.12.1-2.fc41
4.12.2-2.fc41
2
rpm-build-libs
4.19.91-9.fc41
4.19.91-13.fc41
3
glibc-gconv-extra
2.39.9000-18.fc41
2.39.9000-26.fc41
3
sqlite-libs
3.46.0-1.fc41
3.46.0-2.fc41
3
gdb-minimal
14.2-11.fc41
14.2-12.fc41
3
glibc-minimal-langpack
2.39.9000-18.fc41
2.39.9000-26.fc41
3
redhat-rpm-config
292-1.fc41
293-1.fc41
3
python3-urllib3
1.26.18-5.fc41
1.26.18-6.fc41
3
glibc-common
2.39.9000-18.fc41
2.39.9000-26.fc41
3
rpm-libs
4.19.91-9.fc41
4.19.91-13.fc41
3
rpm
4.19.91-9.fc41
4.19.91-13.fc41
3
perl-srpm-macros
1-53.fc40
1-55.fc41
4
libxml2
2.12.7-2.fc41
2.12.8-1.fc41
4
build-reproducibility-srpm-macros
0.2.0-10.fc41
0.3.0-2.fc41
4
openldap
2.6.8-1.fc41
2.6.8-2.fc41
B
add-determinism
0.2.0-10.fc41
0.3.0-2.fc41
B
systemd-libs
256~rc4-2.fc41
256.1-3.fc41
B
add-determinism-nopython
0.2.0-10.fc41
2024-06-12 09:04:41
Package dependencies resolved successfuly
2024-06-12 08:50:07
Package resolution failed
  • Problem: conflicting requests
    - nothing provides python3.12dist(pytest) >= 5 needed by python3-pytest-mock-3.12.0-4.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python3.12dist(jinja2) >= 3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(packaging) >= 21 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides (python3.12dist(docutils) < 0.21~~ with python3.12dist(docutils) >= 0.18.1) needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(imagesize) >= 1.3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(pygments) >= 2.14 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-pip-24.0-5.fc41.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-idna-3.7-2.fc41.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python3.12dist(docutils) < 0.21~~ needed by python3-sphinx_rtd_theme-2.0.0-3.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-hypothesis-6.98.8-3.fc41.noarch from primary-f41-build-6163033
    - nothing provides (python3.13dist(sortedcontainers) < 3~~ with python3.13dist(sortedcontainers) >= 2.1) needed by python3-hypothesis-6.98.8-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package python3-sphinxcontrib-jquery-4.1-7.fc40.noarch from primary-f41-build-6163033 requires python3.12dist(sphinx) >= 1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(jinja2) >= 3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(packaging) >= 21 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides (python3.12dist(docutils) < 0.21~~ with python3.12dist(docutils) >= 0.18.1) needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(imagesize) >= 1.3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(pygments) >= 2.14 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python3.12dist(cryptography) >= 3.1 needed by python3-trustme-1.1.0-3.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(idna) >= 2 needed by python3-trustme-1.1.0-3.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-psutil-5.9.8-3.fc41.x86_64 from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package python3-devel-3.12.3-2.fc41.x86_64 from primary-f41-build-6163033 requires (python3-rpm-generators if rpm-build), but none of the providers can be installed
    - package python3-rpm-generators-14-10.fc40.noarch from primary-f41-build-6163033 requires python3-packaging, but none of the providers can be installed
    - conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-packaging-24.0-3.fc41.noarch from primary-f41-build-6163033
  • Problem: package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6163033 requires python3.12dist(sphinx) >= 4.5, but none of the providers can be installed
    - package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6163033 requires python3-sphinx, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(jinja2) >= 3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(packaging) >= 21 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides (python3.12dist(docutils) < 0.21~~ with python3.12dist(docutils) >= 0.18.1) needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(imagesize) >= 1.3 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(pygments) >= 2.14 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python3.12dist(packaging) >= 20 needed by python3-setuptools_scm-8.0.4-3.fc40.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python(abi) = 3.13 needed by python3-pytest-7.4.3-6.fc41.noarch from primary-f41-build-6163033
  • Problem: conflicting requests
    - nothing provides python3.12dist(idna) needed by python3-trio-0.23.1-3.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(outcome) needed by python3-trio-0.23.1-3.fc40.noarch from primary-f41-build-6163033
    - nothing provides python3.12dist(attrs) >= 20.1 needed by python3-trio-0.23.1-3.fc40.noarch from primary-f41-build-6163033
2024-06-12 08:44:06
Package resolution failed
  • Problem: conflicting requests
    - nothing provides python3.12dist(attrs) >= 20.1 needed by python3-trio-0.23.1-3.fc40.noarch from primary-f41-build-6162980
  • Problem: package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162980 requires python3.12dist(sphinx) >= 4.5, but none of the providers can be installed
    - package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162980 requires python3-sphinx, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162980
  • Problem: package python3-sphinx_rtd_theme-2.0.0-3.fc40.noarch from primary-f41-build-6162980 requires (python3.12dist(sphinx) < 8~~ with python3.12dist(sphinx) >= 5), but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162980
  • Problem: package python3-sphinxcontrib-jquery-4.1-7.fc40.noarch from primary-f41-build-6162980 requires python3.12dist(sphinx) >= 1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162980
  • Problem: conflicting requests
    - nothing provides python3.12dist(attrs) >= 22.2 needed by python3-hypothesis-6.98.8-1.fc41.noarch from primary-f41-build-6162980
  • Problem: conflicting requests
    - nothing provides python3.12dist(pytest) >= 5 needed by python3-pytest-mock-3.12.0-4.fc40.noarch from primary-f41-build-6162980
  • Problem: package python3-trustme-1.1.0-3.fc40.noarch from primary-f41-build-6162980 requires python3.12dist(cryptography) >= 3.1, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(cffi) >= 1.12 needed by python3-cryptography-41.0.7-1.fc40.x86_64 from primary-f41-build-6162980
  • Problem: conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162980
  • Problem: conflicting requests
    - nothing provides python3.13dist(packaging) needed by python3-pytest-7.4.3-6.fc41.noarch from primary-f41-build-6162980
    - nothing provides python3.13dist(iniconfig) needed by python3-pytest-7.4.3-6.fc41.noarch from primary-f41-build-6162980
    - nothing provides python(abi) = 3.13 needed by python3-pytest-7.4.3-6.fc41.noarch from primary-f41-build-6162980
    - nothing provides (python3.13dist(pluggy) < 2~~ with python3.13dist(pluggy) >= 0.12) needed by python3-pytest-7.4.3-6.fc41.noarch from primary-f41-build-6162980
2024-06-12 08:34:12
Package resolution failed
  • Problem: package python3-sphinx_rtd_theme-2.0.0-3.fc40.noarch from primary-f41-build-6162913 requires (python3.12dist(sphinx) < 8~~ with python3.12dist(sphinx) >= 5), but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162913
  • Problem: package python3-sphinxcontrib-jquery-4.1-7.fc40.noarch from primary-f41-build-6162913 requires python3.12dist(sphinx) >= 1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162913
  • Problem: conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162913
  • Problem: package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162913 requires python3.12dist(sphinx) >= 4.5, but none of the providers can be installed
    - package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162913 requires python3-sphinx, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162913
2024-06-12 08:30:20
Package resolution failed
  • Problem: package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162843 requires python3.12dist(sphinx) >= 4.5, but none of the providers can be installed
    - package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162843 requires python3-sphinx, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162843
  • Problem: conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162843
  • Problem: package python3-sphinx_rtd_theme-2.0.0-3.fc40.noarch from primary-f41-build-6162843 requires (python3.12dist(sphinx) < 8~~ with python3.12dist(sphinx) >= 5), but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162843
  • Problem: package python3-sphinxcontrib-jquery-4.1-7.fc40.noarch from primary-f41-build-6162843 requires python3.12dist(sphinx) >= 1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162843
2024-06-12 08:20:11
Package resolution failed
  • Problem: conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162796
  • Problem: package python3-sphinxcontrib-jquery-4.1-7.fc40.noarch from primary-f41-build-6162796 requires python3.12dist(sphinx) >= 1.8, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162796
  • Problem: package python3-sphinx_rtd_theme-2.0.0-3.fc40.noarch from primary-f41-build-6162796 requires (python3.12dist(sphinx) < 8~~ with python3.12dist(sphinx) >= 5), but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162796
  • Problem: package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162796 requires python3.12dist(sphinx) >= 4.5, but none of the providers can be installed
    - package python3-sphinx-autodoc-typehints-1.18.3-7.fc40.noarch from primary-f41-build-6162796 requires python3-sphinx, but none of the providers can be installed
    - conflicting requests
    - nothing provides python3.12dist(babel) >= 2.9 needed by python3-sphinx-1:7.2.6-6.fc40.noarch from primary-f41-build-6162796
complete
2024-06-09 09:38:41
python3-pytest
7.4.3-3.fc40
7.4.3-6.fc41
1
python3-wheel
1:0.43.0-1.fc41
1:0.43.0-3.fc41
1
python3-hypothesis
6.98.8-1.fc41
6.98.8-3.fc41
1
python3-sphinxcontrib-jquery
4.1-7.fc40
4.1-8.fc41
1
python3-trustme
1.1.0-3.fc40
1.1.0-5.fc41
1
python3-psutil
5.9.8-1.fc40
5.9.8-3.fc41
1
python3-setuptools
69.2.0-3.fc41
69.2.0-6.fc41
1
python3-sphinx
1:7.2.6-6.fc40
1:7.2.6-8.fc41
1
python3-packaging
24.0-1.fc41
24.0-3.fc41
1
python3-sphinx-autodoc-typehints
1.18.3-7.fc40
1.18.3-8.fc41
1
python3-pip
24.0-2.fc41
24.0-5.fc41
1
python3-setuptools_scm
8.0.4-3.fc40
8.0.4-5.fc41
1
python3-sniffio
1.3.1-1.fc41
1.3.1-2.fc41
1
python3-idna
3.7-1.fc41
3.7-2.fc41
1
python3-trio
0.23.1-3.fc40
0.23.1-5.fc41
1
python3-devel
3.12.3-2.fc41
3.13.0~b2-3.fc41
1
python3-sphinx_rtd_theme
2.0.0-3.fc40
2.0.0-4.fc41
1
python3-pytest-mock
3.12.0-4.fc40
3.12.0-5.fc41
1
python-rpm-macros
3.12-9.fc41
3.13-1.fc41
2
python3-sphinx-theme-alabaster
0.7.16-3.fc40
0.7.16-5.fc41
2
python3-requests
2.31.0-5.fc41
2.31.0-6.fc41
2
python3-attrs
23.2.0-6.fc41
23.2.0-9.fc41
2
python3-iniconfig
1.1.1-16.fc40
1.1.1-22.fc41
2
python3-snowballstemmer
2.2.0-10.fc40
2.2.0-11.fc41
2
python3-cryptography
41.0.7-1.fc40
41.0.7-2.fc41
2
python-srpm-macros
3.12-9.fc41
3.13-1.fc41
2
findutils
1:4.10.0-1.fc41
1:4.10.0-2.fc41
2
python3-pluggy
1.3.0-3.fc40
1.3.0-5.fc41
2
python3-pygments
2.17.2-3.fc40
2.17.2-6.fc41
2
python3-sortedcontainers
2.4.0-15.fc40
2.4.0-17.fc41
2
python3-libs
3.12.3-2.fc41
3.13.0~b2-3.fc41
2
rpm-build
4.19.91-7.fc41
4.19.91-9.fc41
2
python3-babel
2.15.0-1.fc41
2.15.0-2.fc41~bootstrap
2
python3-imagesize
1.4.1-7.fc40
1.4.1-8.fc41
2
python3-typing-extensions
4.12.1-1.fc41
4.12.1-2.fc41
2
python3
3.12.3-2.fc41
3.13.0~b2-3.fc41
2
python3-docutils
0.20.1-3.fc40
0.20.1-5.fc41
2
python3-outcome
1.2.0-4.fc40
1.2.0-5.fc41
2
python3-jinja2
3.1.4-2.fc41
3.1.4-4.fc41
2
python3-rpm-macros
3.12-9.fc41
3.13-1.fc41
2
rpm-libs
4.19.91-7.fc41
4.19.91-9.fc41
3
zlib-ng-compat
2.1.6-4.fc41
2.1.6-6.fc41
3
libuuid
2.40.1-1.fc41
2.40.1-2.fc41
3
file
5.45-5.fc41
5.45-6.fc41
3
python3-cffi
1.16.0-4.fc40
1.16.0-5.fc41
3
libgcc
14.1.1-4.fc41
14.1.1-5.fc41
3
libselinux
3.6-4.fc40
3.6-6.fc41
3
coreutils
9.5-1.fc41
9.5-2.fc41
3
python-pip-wheel
24.0-2.fc41
24.0-5.fc41
3
gdb-minimal
14.2-9.fc41
14.2-11.fc41
3
python3-urllib3
1.26.18-3.fc40
1.26.18-5.fc41
3
python3-charset-normalizer
3.3.2-3.fc40
3.3.2-4.fc41
3
sqlite-libs
3.45.3-1.fc41
3.46.0-1.fc41
3
rpm-build-libs
4.19.91-7.fc41
4.19.91-9.fc41
3
python3-markupsafe
2.1.5-1.fc41
2.1.5-2.fc41
3
fonts-filesystem
1:2.0.5-14.fc40
1:2.0.5-15.fc41
3
binutils
2.42.50-11.fc41
2.42.50-14.fc41
3
rpm
4.19.91-7.fc41
4.19.91-9.fc41
3
openssl-libs
1:3.2.1-6.fc41
1:3.2.2-1.fc41
3
file-libs
5.45-5.fc41
5.45-6.fc41
4
libstdc++
14.1.1-4.fc41
14.1.1-5.fc41
4
build-reproducibility-srpm-macros
0.2.0-9.fc41
0.2.0-10.fc41
4
libgomp
14.1.1-4.fc41
14.1.1-5.fc41
4
coreutils-common
9.5-1.fc41
9.5-2.fc41
4
libxml2
2.12.7-1.fc41
2.12.7-2.fc41
4
python3-pycparser
2.20-14.fc40
2.20-17.fc41
4
setup
2.15.0-3.fc41
2.15.0-4.fc41
4
fonts-srpm-macros
1:2.0.5-14.fc40
1:2.0.5-15.fc41
4
libmount
2.40.1-1.fc41
2.40.1-2.fc41
B
util-linux
2.40.1-1.fc41
2.40.1-2.fc41
B
systemd-libs
256~rc3-4.fc41
256~rc4-2.fc41
B
util-linux-core
2.40.1-1.fc41
2.40.1-2.fc41
B
binutils-gold
2.42.50-11.fc41
libfdisk
2.40.1-1.fc41
2.40.1-2.fc41
B
audit-libs
4.0.1-2.fc41
4.0.1-3.fc41
B
libcap-ng
0.8.5-1.fc41
0.8.5-2.fc41
B
libsmartcols
2.40.1-1.fc41
2.40.1-2.fc41
B
libsemanage
3.6-3.fc40
3.6-4.fc41
B
python3-ply
3.11-23.fc40
3.11-24.fc41
B
add-determinism
0.2.0-9.fc41
0.2.0-10.fc41
B
add-determinism-nopython
0.2.0-9.fc41
0.2.0-10.fc41
B
libpwquality
1.4.5-9.fc40
1.4.5-10.fc41
B
libblkid
2.40.1-1.fc41
2.40.1-2.fc41
B
libbrotli
1.1.0-3.fc40
1.1.0-4.fc41
B
Previous history